poj 2629 Common permutation

Common permutation
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5059   Accepted: 1519

Description

Given two strings of lowercase letters, a and b, print the longest string x of lowercase letters such that there is a permutation of x that is a subsequence of a and there is a permutation of x that is a subsequence of b.

Input

Input consists of pairs of lines. The first line of a pair contains a and the second contains b. Each string is on a separate line and consists of at most 1,000 lowercase letters.

Output

For each subsequent pair of input lines, output a line containing x. If several x satisfy the criteria above, choose the first one in alphabetical order.

Sample Input

pretty
women
walking
down
the
street

Sample Output

e
nw
et
#include<iostream>
#include<algorithm>
using namespace std;

int comp(char &a,char &b)
{
return a<b;
}

int main()
{
char a[1001];
char b[1001];
int i,j;
int lena,lenb;
int pos;
while(gets(a) && gets(b))
{
lena=strlen(a);
lenb=strlen(b);
sort(a,a+lena,comp);
sort(b,b+lenb,comp);
pos=-1;
for(i=0;i<lena;i++)
{
for(j=pos+1;j<lenb;j++)
{
if(a[i]==b[j])
{
pos=j;
cout<<a[i];
break;
}
}
}
cout<<endl;
}
return 0;
}

posted @ 2011-11-22 12:55  w0w0  阅读(254)  评论(0编辑  收藏  举报