poj 2606 Rabbit hunt

Rabbit hunt
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6017   Accepted: 2943

Description

A good hunter kills two rabbits with one shot. Of course, it can be easily done since for any two points we can always draw a line containing the both. But killing three or more rabbits in one shot is much more difficult task. To be the best hunter in the world one should be able to kill the maximal possible number of rabbits. Assume that rabbit is a point on the plane with integer x and y coordinates. Having a set of rabbits you are to find the largest number K of rabbits that can be killed with single shot, i.e. maximum number of points lying exactly on the same line. No two rabbits sit at one point.

Input

An input contains an integer N (2<=N<=200) specifying the number of rabbits. Each of the next N lines in the input contains the x coordinate and the y coordinate (in this order) separated by a space (-1000<=x,y<=1000).

Output

The output contains the maximal number K of rabbits situated in one line.

Sample Input

6
7 122
8 139
9 156
10 173
11 190
-100 1

Sample Output

5
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
double k[200];
double x[200],y[200];
int n;
int i,j,p;
int cnt;
int num,max_num;
cin>>n;
for(i=0;i<n;i++)
{
cin>>x[i];
cin>>y[i];
}
num=2;
max_num=2;
for(i=0;i<n;i++)
{
cnt=0;
for(j=i+1;j<n;j++)
{
k[cnt]=(y[i]-y[j])/(x[i]-x[j]);
cnt++;
}
sort(k,k+cnt);
num=2;
for(p=0;p<cnt;p++)
{
if(k[p]==k[p+1])
{
num++;
if(max_num<num)
max_num=num;
}
else
{
num=2;
if(max_num<num)
max_num=num;
}
}
}
cout<<max_num<<endl;
return 0;
}

posted @ 2011-11-22 12:53  w0w0  阅读(202)  评论(0编辑  收藏  举报