poj 2350 Above Average

Above Average
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12258   Accepted: 6476

Description

It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.

Input

The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by spaces or newlines, each giving the final grade (an integer between 0 and 100) of a student in the class.

Output

For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.

Sample Input

5
5 50 50 70 80 100
7 100 95 90 80 70 60 50
3 70 90 80
3 70 90 81
9 100 99 98 97 96 95 94 93 91

Sample Output

40.000%
57.143%
33.333%
66.667%
55.556%
#include<iostream>
using namespace std;
int main()
{
int c;
int n;
int i;
int in[1000];
int sum;
int ave;
int total;
cin>>c;
while(c--)
{
cin>>n;
for(i=0;i<n;i++)
cin>>in[i];
sum=0;
total=0;
for(i=0;i<n;i++)
sum+=in[i];
ave=sum/n;
for(i=0;i<n;i++)
{
if(in[i]>ave)
total++;
}
printf("%.3f",total*1.0/n*100);
cout<<"%"<<endl;
}
return 0;
}

posted @ 2011-11-22 10:05  w0w0  阅读(215)  评论(0编辑  收藏  举报