poj 2190 ISBN

ISBN
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12940   Accepted: 4507

Description

Farmer John's cows enjoy reading books, and FJ has discovered that his cows produce more milk when they read books of a somewhat intellectual nature. He decides to update the barn library to replace all of the cheap romance novels with textbooks on algorithms and mathematics. Unfortunately, a shipment of these new books has fallen in the mud and their ISBN numbers are now hard to read.

An ISBN (International Standard Book Number) is a ten digit code that uniquely identifies a book. The first nine digits represent the book and the last digit is used to make sure the ISBN is correct. To verify that an ISBN number is correct, you calculate a sum that is 10 times the first digit plus 9 times the second digit plus 8 times the third digit ... all the way until you add 1 times the last digit. If the final number leaves no remainder when divided by 11, the code is a valid ISBN.

For example 0201103311 is a valid ISBN, since
10*0 + 9*2 + 8*0 + 7*1 + 6*1 + 5*0 + 4*3 + 3*3 + 2*1 + 1*1 = 55.

Each of the first nine digits can take a value between 0 and 9. Sometimes it is necessary to make the last digit equal to ten; this is done by writing the last digit as X. For example, 156881111X is a valid ISBN number.

Your task is to fill in the missing digit from a given ISBN number where the missing digit is represented as '?'.

Input

* Line 1: A single line with a ten digit ISBN number that contains '?' in a single position

Output

* Line 1: The missing digit (0..9 or X). Output -1 if there is no acceptable digit for the position marked '?' that gives a valid ISBN.

Sample Input

15688?111X

Sample Output

1
#include<iostream>
using namespace std;
int main()
{
char isdn[11];
int i,j;
int pos;
int sum;
int weight;
scanf("%s",&isdn);
j=10;
sum=0;
for(i=0;i<11;i++)
{
if(isdn[i]=='?')
{
pos=i;
weight=j;
}
if(isdn[i]=='X')
{
sum+=10*j;
}
if(isdn[i]>='0' && isdn[i]<='9')
{
sum+=(isdn[i]-'0')*j;
}
j--;
}
if(weight==1)
{
for(i=0;i<11;i++)
{
if((sum+weight*i)%11==0)
{
if(i==10)
{
cout<<"X"<<endl;
}
else
{
cout<<(char)(i+'0')<<endl;
}
break;
}
}
if(i==11)
cout<<"-1"<<endl;
}
if(weight!=1)
{
for(i=0;i<10;i++)
{
if((sum+weight*i)%11==0)
{
cout<<(char)(i+'0')<<endl;
break;
}
}
if(i==10)
cout<<"-1"<<endl;
}
return 0;
}

posted @ 2011-11-22 08:40  w0w0  阅读(213)  评论(0编辑  收藏  举报