HDU 1796 How many integers can you find(组合数学-容斥原理)

How many integers can you find


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
12 2 2 3
 

Sample Output
7
 

Author
wangye
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:  1793 1794 1797 1795 1798 
 

题目大意:
给你1个数n,再给m个数,问你1~n-1里面有多少个数能被这m个数的任意一个数整除。

解题思路:
利用容斥原理就可以解决。

解题代码:
#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;

typedef long long ll;
int n,m,a[20];

ll gcd(ll a,ll b){
    return b>0 ? gcd(b,a%b):a;
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        int ans=0;
        vector <int> v;
        for(int i=0;i<m;i++){
            scanf("%d",&a[i]);
            if(a[i]>0) v.push_back(a[i]);
        }
        m=v.size();
        for(int i=1;i<(1<<m);i++){
            int cnt=0;
            ll x=1;
            for(int t=0;t<m;t++){
                if(i&(1<<t)){
                    cnt++;
                    x=x*v[t]/gcd(x,v[t]);
                }
            }
            if( cnt&1 ) ans+=(n-1)/x;
            else ans-=(n-1)/x;
        }
        cout<<ans<<endl;
    }
    return 0;
}



posted @ 2014-07-29 16:22  炒饭君  阅读(139)  评论(0编辑  收藏  举报