HDU 2199 Can you solve this equation? (二分 水题)

Can you solve this equation?


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6023    Accepted Submission(s): 2846


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
2 100 -4
 

Sample Output
1.6152 No solution!
 

Author
Redow
 


一道初学者的二分题,讲课用

#include <iostream>
#include <cstdio>
using namespace std;

double y;

double getfx(double x){
	return 8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6;
}

void computing(){
	if(getfx(100)<y-1e-3 || getfx(0)>y+1e-3){
		printf("No solution!\n");
		return;
	}
	double l=0,r=100;
	while(r-l>1e-6){
		double mid=(l+r)/2;
		if(getfx(mid)>y) r=mid;
		else l=mid;
	}
	printf("%.4lf\n",r);
}

int main(){
	int t;
	scanf("%d",&t);
	while(t-- >0){
		scanf("%lf",&y);
		computing();
	}
	return 0;
}





posted @ 2013-11-19 22:29  炒饭君  阅读(119)  评论(0编辑  收藏  举报