A+B for Input-Output Practice (V) <入门练手题>

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6614    Accepted Submission(s): 4979
 
Problem Description
Your task is to calculate the sum of some integers.
 
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
 
Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
 
Sample Output
10
15
 
代码:
#include<stdio.h>
int main(void)
{
	int a,b,i,N,M;
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d",&M);
		for(i=0,b=0;i<M;i++)
		{
			scanf("%d",&a);
			b+=a;
		}
		printf("%d\n",b);
	}
	return 0;
}

此题注意是否超时:若使用两个for循环嵌套会超时!!

  

posted @ 2012-10-09 18:55  莫邪257  阅读(186)  评论(0编辑  收藏  举报