HDU1019 Least Common Multiple(多个数的最小公倍数)

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. 

InputInput will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer. 
OutputFor each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer. 
Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

这道题挺简单的,但我居然想着去分解质因数然后乘一遍,又果断的TLE了.但其实真的很简单,不断地读入一个数,然后求它和之前所有数的lcm,这个怎么求呢?除去两数的gcd即可.说起来还是太菜了....

代码如下:
#include<cstdio>
using namespace std;

long long ans=1,n,i,x;

long long gcd(long long a,long long b)
{
    if(b>a)
    {
        long long w=a;a=b;b=w;
    }
    if(a%b==0)
    {
        return b;
    }
    else
    {
        return gcd(b,a%b);
    }
}

int main()
{
    long long t;
    scanf("%lld",&t);
    while(t--)
    {
        ans=1;
        scanf("%lld",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%lld",&x);
            ans*=x/gcd(ans,x);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

 

 

 

 

每日刷题身体棒棒!

posted @ 2017-09-03 20:14  Styx-ferryman  阅读(188)  评论(0编辑  收藏  举报