HDU1171 Big Event In HDU

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output
20 10
40 40
————————————————————————————————————————————————————————————
    这道题强就强在它的思维……它规定B不得超过A,那么B就不能超过总数的向下取整的一半,那这样就转化成了一个背包问题,其重量就是它本身的价值,那也就变成了一道普通的01背包题目,即尽量的装满容量为sum/2的背包……还是得多想想,可以多往几个模板里套套试试看……
——————————————————————————code————————————————————————————————

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<vector>
#include<algorithm>
#include<string>
#include<queue>
#include<climits>
#include<map>
#include<stack>
#include<list>
#define file_in freopen("input.txt","r",stdin)
#define MAX 8000
#define HASH 100019
using namespace std;
#define ll long long
#define FF(x,y) for(int i=x;i<y;i++)
int dp[100005];
int main() {
    int num;
    while (scanf("%d", &num))
    {
        if (num < 0)break;
        memset(dp, 0, sizeof(dp));
        vector<int>w;
        int sum = 0;
        for (int i = 0; i < num; i++)
        {
            int ww, n;
            scanf("%d %d", &ww, &n);
            sum += n*ww;
            for (int i = 0; i < n; i++)
            {
                w.push_back(ww);
            }
        }
        for (int i = 0; i < w.size(); i++)
        {
            for (int j = sum / 2; j > 0; j--)
            {
                if (w[i] <= j)
                    dp[j] = max(dp[j], dp[j - w[i]]+w[i]);
            }
        }
        cout << sum - dp[sum / 2] <<" "<< dp[sum / 2]<<endl;
    }
}
/*
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
*/

posted @ 2017-03-13 17:10  duskcloudxu  阅读(247)  评论(0编辑  收藏  举报