九度OJ 1439:Least Common Multiple

题目描述:

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入:

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出:

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入:
2
3 5 7 15
6 4 10296 936 1287 792 1
样例输出:
105
10296
#include <cstdio>
//5 7 15
// 1  1  5
// 35 105 15
int gcd(int n,int m){
    return m == 0 ? n: gcd(m,n%m);
}
int main(){
    /*
    int n,m;
    while(scanf("%d%d",&n,&m) != EOF){
        printf("%d\n",gcd(n,m));
    }*/
    int n,m;
    int b,temp;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&m);
        temp = 1;
        for(int i = 0;i < m;i++){
            scanf("%d",&b);
            temp = b/gcd(temp,b)*temp;
            //a = temp;
        }
        printf("%d\n",temp);
    }
}

 

posted @ 2017-06-29 17:26  肉松松鼠  阅读(128)  评论(0编辑  收藏  举报