Team Formation

Time Limit: 3 Seconds      Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be AB, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. AB > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

Author: LIN, Xi
Source: The 12th Zhejiang Provincial Collegiate Programming Contest

copy:

题意:给你n 个数 ,让你找出其中有多少组数字 a 异或b 大于max(a, b)

题解:首先了解异或运算的方式 相同为0 不同为1 可以知道如果要增大肯定是要不同的位多于相同的位,其次需要知道 2的n次方等于2的n-1次访加到2的1次访再加1,即最高位影响大于低位之和,也就是说只有某个数字它和其他数字最大位不相同,则异或必然大于 max(a, b);

#include <iostream> 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int value[100005];
//a[] 表示最高位为1的数字数目 ; 1 ^ 1=0;  <o ^ 0 =0, 1 ^ 0=1,  0^1= 1> (无影响);
int main()
{
    int T, mark[31], n, a[31];
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &value[i]);
        }
        sort(value+1, value+1+n);
        int sum = 0;
        memset(a, 0, sizeof(a));
        for(int i = 1; i <= n; i++)
        {
            memset(mark, 0, sizeof(mark));
            int num = 0;
            sum += (i-1);
            while(value[i])
            {
                mark[num++] = value[i]%2;
                value[i] /= 2;
            }
            int maxx;
            for(int i = 0; i < num; i++)
            {
                if(mark[i]) sum -= a[i], maxx = i;  //1 ^ 1=0; 
            }
            a[maxx]++; 
        }
        printf("%d\n", sum);
    }
}

 

posted on 2016-05-01 18:24  cleverbiger  阅读(210)  评论(0编辑  收藏  举报