DP动态规划——hdu 1008 Common Subsequence(最长公共子序列)

http://acm.hdu.edu.cn/showproblem.php?pid=1159点击打开链接

 

 

              Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13471    Accepted Submission(s): 5534


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

Sample Input
   
abcfbc abfcab programming contest abcd mnp
 

Sample Output
   
4 2 0

 又是一个dp问题。

找到其动态方程,程序就出来了一大半了。我做dp 问题的时候习惯的画一个表格。


 

a

b

f

c

a

b

a

1

1

1

1

1

1

b

1

2

2

2

2

2

c

1

2

2

3

3

3

f

1

2

3

3

3

3

b

1

2

3

3

3

4

c

1

2

3

4

4

4


有了这个 dp 方程就好理解了:

当   a[ i ] ==b[ i ]    时: dp[ i ][ j ]=dp[ i-1 ][ j-1 ]  +1;

当   a[ i ] !=b[ i ]     时:  max( dp[ i-1 ][ j ] , dp[ i ][ j-1 ] ).


下面就是代码了:

#include<iostream>
#include<string.h>
using namespace std;

#define M 505
#define max(a,b) a>b?a:b
int dp[M][M];

int main()
{
	int lena,lenb,i,j;
	char a[M],b[M];
	for(i=0;i<M;i++) //初始化
		dp[0][i]=dp[i][0]=0;
	while(cin>>a+1>>b+1) //从 a[1],b[1] 开始输入
	{
		lena=strlen(a)-1;
		lenb=strlen(b)-1;
		for(i=1;i<=lena;i++)
		{
			for(j=1;j<=lenb;j++)
			{
				if(a[i]==b[j])
					dp[i][j]=dp[i-1][j-1]+1;
				else
					dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
			}
		}
		cout<<dp[lena][lenb]<<endl;
	}
	return 0;
}





posted @ 2012-08-12 23:04  爱生活,爱编程  阅读(334)  评论(1编辑  收藏  举报