相同的雪花//和poj3349差不多

相同的雪花

时间限制:1000 ms  |  内存限制:65535 KB
难度:4
描述
You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.
输入
The first line of the input will contain a single interger T(0<T<10),the number of the test cases.
The first line of every test case will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.
输出
For each test case,if all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.
样例输入
1
2
1 2 3 4 5 6
4 3 2 1 6 5
样例输出
Twin snowflakes found.
#include <iostream>//poj3349
#include <stdio.h>
#include <vector>
#define MX 87719
using namespace std;
struct node
{
	int arms[6];	
};
vector<node> twin[MX];
bool judge(node &snow1,node &snow2)
{
	int a[6]={0};
	int i,j,k=0;
	for (i=0;i<6;i++)
	{
		if (snow1.arms[0]==snow2.arms[i])
		{
			a[k++]=i;
		}
	}
	if (k==0)
	{
		return false;
	} 
	
	for (i=0;i<k;i++)
	{
		bool flg=true;
		for (j=1;j<6;j++)
		{
			if (snow1.arms[j]!=snow2.arms[(a[i]+j)%6])
			{
				flg=false;
				break;
			}
		}
		if(flg==true)
		{
			return true;
		}	
		flg=true;
		for (j=1;j<6;j++)
		{
			if (snow1.arms[j]!=snow2.arms[(a[i]-j+6)%6])
			{
				flg=false;
				break;
			}
		}
		if (flg==true)
		{
			return true;
		}
	}	
	return false;
}
int hash(node &snow)
{
	return ((snow.arms[0]+snow.arms[2]+snow.arms[4])^(snow.arms[1]+snow.arms[3]+snow.arms[5]))%MX;
}
int main()
{
	int t,i,j,ss,sum;
	node da;
	cin>>t;	
loop:
	while(t--)
	{
		scanf("%d",&ss);
		for(i=0;i<MX;i++)
		{
			while(!twin[i].empty())
			{
				twin[i].pop_back();
			}
		}
		while(ss--)
		{
			sum=0;
			for (i=0;i<6;i++)
			{
				scanf("%d",&da.arms[i]);
			}
			twin[hash(da)].push_back(da);		
		}
		for (i=0;i<MX;i++)
		{
			for (j=0;j<twin[i].size();j++)
			{
				for (int k=j+1;k<twin[i].size();k++)
				{
					if (judge(twin[i][j],twin[i][k]))
					{
						printf("Twin snowflakes found.\n");
						goto loop;
					}
				}			
			}
		}
		printf("No two snowflakes are alike.\n");
	}
	return 0;
}

posted @ 2011-10-25 19:14  qijinbiao1  阅读(478)  评论(0编辑  收藏  举报