hdoj--1068--Girls and Boys(最大独立集)

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9464    Accepted Submission(s): 4320


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
5 2
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1150 1151 1281 1507 1528 

最大独立集=所有点数-最大匹配数,这一道题的最大匹配数会有重复,所以要除以2
二分图,反反复复的匈牙利算法
#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>map[2000];
int used[2000],pipei[2000];
int find(int x)
{
	for(int i=0;i<map[x].size();i++)
	{
		int y=map[x][i];
		if(!used[y])
		{
			used[y]=1;
			if(!pipei[y]||find(pipei[y]))
			{
				pipei[y]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(pipei,0,sizeof(pipei));
		for(int i=0;i<n;i++)
		{
			map[i].clear();
			int a,b,t;
			scanf("%d: (%d)",&a,&t);
			while(t--)
			{
				scanf("%d",&b);
				map[a].push_back(b);
			}
		}
		int sum=0;
		for(int i=0;i<n;i++)
		{
			memset(used,0,sizeof(used));
			sum+=find(i);
		}
		printf("%d\n",n-sum/2);
	}
	return 0;
}


posted @ 2016-01-31 17:09  上弦月307  阅读(383)  评论(0编辑  收藏  举报