HDU 5753Permutation Bo

Permutation Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 114    Accepted Submission(s): 67
Special Judge


Problem Description
There are two sequences h1hn and c1cnh1hn is a permutation of 1n. particularly, h0=hn+1=0.

We define the expression [condition] is 1 when condition is True,is 0 when condition is False.

Define the function f(h)=ni=1ci[hi>hi1  and  hi>hi+1]

Bo have gotten the value of c1cn, and he wants to know the expected value of f(h).
 

 

Input
This problem has multi test cases(no more than 12).

For each test case, the first line contains a non-negative integer n(1n1000), second line contains n non-negative integer ci(0ci1000).
 

 

Output
For each test cases print a decimal - the expectation of f(h).

If the absolute error between your answer and the standard answer is no more than 104, your solution will be accepted.
 

 

Sample Input
4 3 2 4 5 5 3 5 99 32 12
 

 

Sample Output
6.000000 52.833333
 

 

很容易证明  中间一个比两遍大的概率是1/3  ,端点的概率1/2

乘一下就是期望了 

/* ***********************************************
Author        :guanjun
Created Time  :2016/7/26 16:00:08
File Name     :p302.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 10010
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;
priority_queue<int,vector<int>,greater<int> >pq;
struct Node{
    int x,y;
};
struct cmp{
    bool operator()(Node a,Node b){
        if(a.x==b.x) return a.y> b.y;
        return a.x>b.x;
    }
};

bool cmp(int a,int b){
    return a>b;
}
int c[maxn];
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    int n;
    while(cin>>n){
        for(int i=1;i<=n;i++){
            scanf("%d",&c[i]);
        }
        double ans=0;
        ans+=(c[1]+c[n])/2.0;
        for(int i=2;i<n;i++){
            ans+=c[i]/3.0;
        }
        printf("%.6f\n",ans);
    }
    return 0;
}

 

posted on 2016-07-26 19:10  Beserious  阅读(185)  评论(0编辑  收藏  举报