L2-006 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

主要思路:后序遍历中找到根节点,在中序遍历中分出左子树与右子树,递归。
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
int a[31],b[31];
queue<int>q;
vector<int>v;
vector<int>::iterator it;
struct treenode
{
    int l,r;
}t[31];
int findtree(int a1,int a2,int b1,int b2)
{
    int root,pos,i;
    if (a2-a1==0)//若长度为1,则为叶节点 
        return a1;
    if (a2-a1<0)
        return -1;
    root=a2;
    for (i=b1;i<=b2;i++)//在中序遍历中找出根节点 
        if (a[root]==b[i])
        {
            pos=i;break;
        }
    t[root].l=findtree(a1,a1+pos-b1-1,b1,pos-1);
    t[root].r=findtree(a1+pos-b1,a2-1,pos+1,b2);
    return root;//返回根节点位置 
} 
void printtree(int n) 
{
    int temp,left,right;
    q.push(n);
    while (!q.empty())//队列为空则层序遍历完成 
    {
        temp=q.front();
        q.pop();
        v.push_back(a[temp]);//将移出的根节点放入vector中 
        if (t[temp].l!=-1)
            q.push(t[temp].l);
        if (t[temp].r!=-1)
            q.push(t[temp].r);
    }
}//层序遍历,将根节点移出队列,将其子节点移入队列 
int main()
{
    int n,i;
    cin>>n;
    for (i=0;i<n;i++)
    {
        t[i].l=t[i].r=-1;
        cin>>a[i];
    }
    for (i=0;i<n;i++)
        cin>>b[i];
    findtree(0,n-1,0,n-1);//树的重建 
    printtree(n-1);//层序遍历 
    cout<<*v.begin();
    for (it=v.begin()+1;it!=v.end();it++)
        cout<<' '<<*it;
    cout<<endl;
    return 0;
}

 

posted @ 2019-03-29 16:25  20190315  阅读(978)  评论(0编辑  收藏  举报