To the Max

 

Description

 


Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.

Input

 


The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

 


Output the sum of the maximal sub-rectangle.

Sample Input

 

40 -2 -7 0 9 2 -6 2-4 1 -4  1 -18  0 -2

Sample Output

 

15
/********代码******枚举*****DP***************/

 

代码
#include<stdio.h>
int main()
{
 int n,i,j,k,l,ii,h,max,Max;
 int map[101][101],sum[101],s[101];
 while(scanf("%d",&n)!=EOF){
  for(i=0;i<n;i++){  
   for(j=0;j<n;j++) 
    scanf("%d",&map[i][j]);
  }  Max=0; 
  for(i=0;i<n;i++){
   for(j=i;j<n;j++){ //从第i列到第j列
    for(k=0;k<n;k++)
     sum[k]=s[k]=0;
    max=-127;
    for(k=0;k<n;k++){
     for(l=i;l<=j;l++)
      s[k]+=map[k][l]; //s[k]为敌k行的值(从第i列到第j列)
     if(sum[k]>0)
      sum[k+1]=sum[k]+s[k]; //sum[k]为到k行是的最大值(从第i列到第j列) 
     else sum[k+1]=s[k];   
     if(sum[k+1]>max)max=sum[k+1]; //max记录最大值(从第i列到第j列) 
    }  
    if(max>Max)       //Max记录总的最大值   
     Max=max;  
   }
  }
  printf("%d\n",Max);
 }
 return 0;
}

 

posted @ 2010-07-14 15:54  戮微扬  阅读(169)  评论(0编辑  收藏  举报