poj3579_查找第k大是数_用两次二分

Median
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9602   Accepted: 3350

Description

Given N numbers, X1X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1X2, ... , XN, ( X≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

题意

给你n个数,然后求它们两两相减的绝对值,然后找出这些绝对值的中中位数。 解题思路:

  1. 先对n个数排序,那么最后的结果ans一定满足0<=ans<an-a1
  2. 第二如何判断ans就是我们需要求的值能,我们用二分进行逼近。l=0,r=an-a1,mid=(l+r)/2;
  3. 二分如何逼近呢,如何判断我们要求的答案ans是在[l,mid]还是在[mid,r]部分呢?
  4. 很明显是原数组两个数相减的绝对值<mid个数,和>mid的个数进行比较。(绝对值的个数<mid,ans在[mid,r]区间,否则在[l,mid]区间内
  5. 如何判段两数绝对值<mid的个数呢?
  6. 如何求一个数减去a[0]的值小于mid的个数,我们找到一个a[i]>=a[0]+mid时最小的一个i,那么数组[0,i)值减去a[0],都小于mid,这样枚举i就可以求得两数相减差值小于mid的个数。
  7. #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    
    const int MAXN=1000005;
    int val[MAXN];
    int N,M;
    
    
    bool calc(int mid){
        int sum=0;
        //这儿如何计算绝对值<mid的个数.
        for(int i=0;i<N;i++)
            sum+=((lower_bound(val+i,val+N,val[i]+mid+1)-(val+i))-1);
        return sum>=M;
    }
    
    int main(){
        while(scanf("%d",&N)!=EOF){
    
        for(int i=0;i<N;i++){
            scanf("%d",&val[i]);
        }
        M=(N*(N-1)/2+1)/2;
        sort(val,val+N);
        int l=0,r=val[N-1]-val[0];
    
        while(r-l>1){
            int mid=(l+r)>>1;
            if(calc(mid))
                r=mid;
            else
                l=mid;
        }
        cout<<r<<endl;
        }
        return 0;
    }
    

      

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 1111111;

int n;
int x[maxn];
long long m;

bool C(int mid) {
    long long cnt = 0;
    for(int i = 0; i < n; i++)
        cnt += x+n-lower_bound(x+i+1, x+n, x[i]+mid);
    return cnt <= m/2;      //等于号是因为,cnt计算的是比mid大的个数
}

int main() {
    while(~scanf("%d", &n)) {
        for(int i = 0; i < n; i++)
            scanf("%d", &x[i]);
        sort(x, x+n);
        m = n*(n-1)/2;      //新数列的个数就是C_N_2(组合数),N是原数列的个数
        int L = 0, R = *max_element(x, x+n);
        while(R-L > 1) {
            int mid = (L+R)/2;
            if(C(mid)) R = mid;
            else L = mid;
        }
        printf("%d\n", L);

    }
    return 0;
}

  

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,num[100010],k,mi;
int divi(int pos)
{ int l=1,r=pos-1,mid;
  while(l<=r)
  { mid=(l+r)/2;
    if(num[pos]-num[mid]<=mi)
     r=mid-1;
    else
     l=mid+1;
  }
  return l;
}
bool solve()
{ int ans=0,i;
  for(i=2;i<=n;i++)
   ans+=i-divi(i);
  if(ans>=k)
   return true;
  else
   return false;
}
int main()
{ int i,j,l,r,ans;
  while(~scanf("%d",&n))
  { for(i=1;i<=n;i++)
     scanf("%d",&num[i]);
    sort(num+1,num+1+n);
    k=n*(n-1)/2;
    if(k%2==0)
     k/=2;
    else
     k=(k+1)/2;
    l=1;r=1000000000;
    while(l<=r)
    { mi=(l+r)/2;
      if(solve())
       r=mi-1;
      else
       l=mi+1;
    }
    printf("%d\n",l);
  }
}

  

posted @ 2018-05-10 10:45  xianbeigg  阅读(150)  评论(0编辑  收藏  举报