UVA 10041 (13.08.25)

 Problem C: Vito's family 

 

Background 

The world-known gangster Vito Deadstone is moving to New York. He hasa very big family there, all of them living in Lamafia Avenue. Sincehe will visit all his relatives very often, he is trying to find ahouse close to them.

 

Problem 

Vito wants to minimize the total distance toall of them and has blackmailed you to write a program that solves his problem.

 

Input 

The input consists of several test cases. The first line contains the number of test cases.

For each testcase you will be given the integer number of relatives r (0 < r < 500)and the street numbers (also integers) $s_1, s_2, \ldots, s_i, \ldots, s_r$wherethey live (0 < si < 30000 ). Note that several relatives could live inthe same street number.

 

Output 

For each test case your program must write the minimal sum ofdistances from the optimal Vito's house to each one of hisrelatives. The distance between two street numbers s i and s j is d ij= | s i- s j|.

 

Sample Input 

2
2 2 4 
3 2 4 6

Sample Output 

2
4

题意:

给主人公找个安家的位置, 使得与所有邻居距离的和最小~


思路:

找中位数, 然后所有的距离减去中位数即可

水题~


AC代码:

 

#include<stdio.h>
#include<algorithm>

using namespace std;

int R[555];

int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        int r;
        scanf("%d", &r);
        for(int i = 0; i < r; i++)
            scanf("%d", &R[i]);
        sort(R, R+r);
        int mid = R[r/2];
        int sum = 0;
        for(int i = 0; i < r; i++) {
            if(R[i] > mid)
                sum += R[i] - mid;
            else 
                sum += mid - R[i];
        }
        printf("%d\n", sum);
    }
    return 0;
}

 

 

 

posted @ 2013-08-26 20:14  pangbangb  阅读(182)  评论(0编辑  收藏  举报