书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

叉乘+二分解决POJ 2318

 

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
 
刚刚开始看这道题的时候也是一头的雾水。
经过在网上不停的搜索,终于还是大彻大悟
了。下面说一下核心。
以第一组测试数据的p0(1, 5)来说,很明
显,它就在第一个格子里面了。现在我们要
做的工作就是说明它在以p1(3, y1)和
p2(1, y2)为端点的线段的左边。这个就
要用到叉乘的性质了。
叉乘的性质如下:

  (1). P x Q > 0; 表示P在Q的顺时针方向;

  (2). p x Q < 0; 表示P在Q的逆时针方向;

  (3). P x Q = 0; 表示P和Q是共线的,

但是可能同向也可能反向.

现在来确定P和Q,学过数学的人对于这个就不是

什么问题了。但是有个关键点,那就是P和Q要

共起点为,这个相当的重要。

P可以是p1-p2,那么Q就是p0-p2

P可以是p0-p1,那么Q就是p2-p1

一定要对应起来,不然就错。


View Code
#include "iostream"
using namespace std;
double y1, y2, p[5005][2];
double Check(int t, double x, double y) //这个就是叉乘了
{
    return (p[t][1]-p[t][0])*(y-y2) - (y2-y1)*(x-p[t][1]);
}
int main()
{
    int ans[5005], i, n, m, low, high, mid;
    double x, y, x1, x2;
    while(cin>>n && n)
    {
        memset(ans, 0, sizeof(ans));
        cin>>m>>x1>>y1>>x2>>y2;
        for(i=1; i<=n; i++)
            cin>>p[i][0]>>p[i][1];
        p[0][0]=x1; p[0][1]=x1;
        p[n+1][0]=x2; p[n+1][1]=x2;
        for(i=0; i<m; i++)
        {
            low = 0; high = n+1;
            mid = (low+high)/2;
            cin>>x>>y;
            if(Check(0, x, y)==0)
                mid = 0;
            else if(Check(n+1, x, y)==0)
                mid = n;
            else 
            {
                while(low<high)
                {
                    if(Check(mid, x, y)<0)
                    {
                        high = mid-1;
                        mid = (low+high)/2;
                    }
                    else
                    {
                        low = mid+1;
                        mid = (low+high)/2;
                    }
                }
                if(Check(mid, x, y)<0)
                    mid--;
            }
            ans[mid]++;
        }
        for(i=0; i<=n; i++)
            cout<<i<<": "<<ans[i]<<endl;
        cout<<endl;
    }
    return 0;
}

 

 

posted on 2011-10-20 22:43  More study needed.  阅读(440)  评论(0编辑  收藏  举报

导航

书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!