HDU 6063 RXD and math(数学 )

这里写图片描述
Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers n,k.

Output
For each test case, output “Case #x: y”, which means the test case number and the answer.

Sample Input
10 10

Sample Output
Case #1: 999999937

快速幂水过
注意取余


#include<cstdio>
using namespace std;
const int mod=1e9+7;
long long pow(long long a,long long n)
{
    long long text=1;
    while (n)
    {
        if (n&1) text = (text%mod)*(a%mod)%mod;
        a = (a%mod)*(a%mod)%mod;
        n >>= 1;
    }
    return text;
}
int main()
{
    long long n,k;
    int i=1;
    while(~scanf("%lld%lld",&n,&k))
    {
        long long text=pow(n,k);
        printf("Case #%d: %lld\n",i++,text);
    }
    return 0;
}

posted @ 2017-08-01 17:04  南风古  阅读(163)  评论(0编辑  收藏  举报