HDU 4791 & ZOJ 3726 Alice's Print Service (数学 打表)

题目链接:

HDU:http://acm.hdu.edu.cn/showproblem.php?pid=4791

ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5072


Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 
Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105 ). The second line contains 2n integers s1, p1 , s2, p2 , ..., sn, pn (0=s1 < s2 < ... < sn ≤ 109 , 109 ≥ p1 ≥ p2 ≥ ... ≥ pn ≥ 0).. The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1..n-1). The price when printing no less than sn pages is pn cents per page. The third line containing m integers q1 .. qm (0 ≤ qi ≤ 109 ) are the queries.
 
Output
For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.
 
Sample Input
1 2 3 0 20 100 10 0 99 100
 
Sample Output
0 1000 1000
 
Source


题意:

打印纸张,随着张数的添加,每张的价格非递增,给出 m 个询问打印的张数,求出最小的花费。

PS:

保留打印a[i]份分别须要的钱,从后往前扫一遍,保证取得最优解。

然后再找到所打印的张数的区间,与没有多打印,仅仅打印m张所需的花费比較!


HDU代码例如以下:

#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <iostream>
#define INF 1e18
using namespace std;

const int maxn=100017;
typedef __int64 LL;

LL s[maxn],p[maxn],c[maxn];

int main()
{
    int T;
    int n, m;
    LL tt;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; i++)
        {
            scanf("%I64d%I64d",&s[i],&p[i]);
        }

        LL minn = INF;
        for(int i = n-1; i >= 0; i--)
        {
            minn = min(s[i]*p[i],minn);
            c[i] = minn;
        }
        for(int i = 0; i < m; i++)
        {
            scanf("%I64d",&tt);
            if(tt>=s[n-1])//最后
                printf("%I64d\n",tt*p[n-1]);
            else
            {
                int pos = upper_bound(s,s+n,tt)-s;
                LL ans = tt*p[pos-1];
                ans = min(ans,c[pos]);
                printf("%I64d\n",ans);
            }
        }
    }
    return 0;
}


ZJU代码例如以下:

#include <cstdio>
#include <algorithm>
#include <iostream>
#define INF 1e18
using namespace std;

const int maxn = 100017;
typedef long long LL;

LL s[maxn], p[maxn], c[maxn];

int main()
{
    int T;
    int n, m;
    LL tt;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; i++)
        {
            scanf("%lld%lld",&s[i],&p[i]);
        }

        LL minn = INF;
        for(int i = n-1; i >= 0; i--)
        {
            minn = min(s[i]*p[i],minn);
            c[i] = minn;
        }
        for(int i = 0; i < m; i++)
        {
            scanf("%lld",&tt);
            if(tt>=s[n-1])//最后
                printf("%lld\n",tt*p[n-1]);
            else
            {
                int pos = upper_bound(s,s+n,tt)-s;
                LL ans = tt*p[pos-1];
                ans = min(ans,c[pos]);
                printf("%lld\n",ans);
            }
        }
    }
    return 0;
}


posted @ 2015-02-15 09:16  mengfanrong  阅读(275)  评论(0编辑  收藏  举报