hdu 1159 最长公共字串

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

Sample Output
4 2 0
最长公共子串,用矩阵dp更容易解答:(以第一个例子为例)

(图为转载)

由图可得dp状态转移方程式:if(a[i]==b[j])

dp[i][j]=dp[i-1][j-1]+1;

else   dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

有了状态转移方程之后再解题会变得很容易,如代码所示:

#include <iostream>
#include <cstdio>
#include <cstring>
#include<algorithm>
using namespace std;
char a[1005],b[1005];
int dp[1005][1005];
int main()
{

    while(cin>>a>>b)
    {
        int l1=strlen(a),l2=strlen(b);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=l1;i++)
            for(int j=1;j<=l2;j++)
        {
            if(a[i-1]==b[j-1])
                dp[i][j]=dp[i-1][j-1]+1;
            else
            dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        }
        cout<<dp[l1][l2]<<endl;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
    }
    return 0;
}




posted @ 2015-05-10 21:15  martinue  阅读(125)  评论(0编辑  收藏  举报