hdu1217(floyd算法)

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

经典的floyd变形啊~!!

竟然将货币汇率都能引进最短路~!!!!

而且这个最短路就不是简单的加法啦~(其实乘法更简单。。。。)

直接上代码吧!不过恕我多啰嗦一句最后判断dis[i][i]是否大于1的原因就是相当于我们floyd了一遍之后最大的汇率转变已经存到了dis[i][i]之中,这就是floyd的精髓:——dp!

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const double maxn=100000000;
char ss[33][33];
double dis[33][33];
int main()
{
    int n,m,o=1;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<33;i++)
        for(int j=0;j<33;j++)
        dis[i][j]=i==j?1:0;

    for(int i=0;i<n;i++)
    scanf("%s",ss[i]);
    scanf("%d",&m);
    for(int i=0;i<m;i++)
    {
        double hh=0;
        char s0[33],s1[33];
        scanf("%s%lf%s",s0,&hh,s1);
        int k1,k2;
        for(int j=0;j<n;j++)
        {
        if(strcmp(s0,ss[j])==0)
            k1=j;
        if(strcmp(s1,ss[j])==0)
            k2=j;
        }
        dis[k1][k2]=hh;
    }

        for(int k=0;k<n;k++)
            for(int i=0;i<n;i++)
                for(int j=0;j<n;j++)
                    dis[i][j]=max(dis[i][j],dis[i][k]*dis[k][j]);
        int flag=0;
        for(int i=0;i<n;i++)
        if(dis[i][i]>1.0)
        {
            printf("Case %d: Yes\n",o++);flag=1;break;
        }
        if(flag==0)printf("Case %d: No\n",o++);
    }
    return 0;
}

posted @ 2015-08-19 22:16  martinue  阅读(476)  评论(0编辑  收藏  举报