hdu1013

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
24 39 0
 

Sample Output
6 3

太坑了,不告诉数据范围,难怪这么简单。。。。

输入的数据我测试到了最小的输入202个数字,也就是说根本用int和long long存不下。。。。。必须开数组了。。然后,后面的模拟很水了……

#include <iostream>
#include <stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int main()
{
    char a[202];
    while(cin>>a&&a[0]!='0')
    {
           int ans=0,l=strlen(a);
           for(int i=0;i<l;i++)
            ans+=a[i]-'0';
            if(ans<10)
            {
                cout<<ans<<endl;continue;
            }
            else
            {
                int t=10,n=ans;
            while(t--)
            {
                ans=0;
                while(n)
                {
                    ans+=n%10;n/=10;
                }
                if(ans<10)
                {
                    cout<<ans<<endl;break;
                }else
                n=ans;
            }
            }
    }
    return 0;
}


posted @ 2015-09-23 20:18  martinue  阅读(114)  评论(0编辑  收藏  举报