hdu1520(树形dp入门)

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7954    Accepted Submission(s): 3462


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
5

题意:一个公司要举办party,不过每一个员工都不愿意和自己的上级在一起,因为这样自己会不开心,而每个人参加party都有一个开心的程度,同时给出来上下级之间的关系,让我们求最大的开心程度是多少。

这题用来树形dp入门,首先就是如何来建树的问题和怎样dp的问题,我们直接用一个数组f[i]来表示第i个人的上司是谁,这样通过层层递进来找到最大的大boss,也就是一棵树的根,然后,用dfs的方式来进行层层搜索,同时dp。

具体的dp过程也就是用dp[i][0]表示如果这个人不来时候的最大开心程度,dp[i][1]表示这个人来的时候的最大开心程度,如果树上面的父亲节点x不来,那么dp[x][0]+=max(dp[i][0],dp[i][1]);,如果树上的父亲节点x来(意味着子节点不会来),那么dp[x][1]+=dp[i][0];

自己的代码(93MS):

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
const int N=6010;
int m,n;
int dp[N][2],rd[N];
vector <int>tu[N];
void dfs(int x)
{
    int l=tu[x].size();
    for(int i=0;i<l;i++)
    {
        int t=tu[x][i];
        dfs(t);
        dp[x][0]+=max(dp[t][1],dp[t][0]);
        dp[x][1]+=dp[t][0];
    }
}

int main()
{
        while(~scanf("%d",&n))
       {
           for(int i=1;i<=n;i++)
        tu[i].clear();
        memset(rd,0,sizeof(rd));
       for(int i=1;i<=n;i++)
       {
           scanf("%d",&dp[i][1]);
           dp[i][0]=0;
       }
       int x,y;
       while(~scanf("%d%d",&x,&y)&&x+y)
           tu[y].push_back(x),rd[x]++;
        int ans=-1;
        for(int i=1;i<=n;i++)
            if(rd[i]==0)///防止不止一个根节点
            {dfs(i);ans=max(ans,max(dp[i][0],dp[i][1]));}
        cout<<ans<<endl;
       }
}


跟网上学习的代码(780MS):

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
const int N=6010;
int dp[N][2];
int vis[N],f[N];
int n;
void dfs(int x)
{
    vis[x]=1;
    for(int i=1;i<=n;i++)
    {
        if(f[i]==x&&!vis[i])
        {
            dfs(i);
            dp[x][0]+=max(dp[i][0],dp[i][1]);
            dp[x][1]+=dp[i][0];
        }
    }
}
int main()
{
    while(cin>>n)
    {
        memset(vis,0,sizeof(vis));
        memset(dp,0,sizeof(dp));
        memset(f,0,sizeof(f));
        for(int i=1;i<=n;i++)
            scanf("%d",&dp[i][1]);
        int a,b,root=1;
        while(~scanf("%d%d",&a,&b)&&a+b)
        f[a]=b,root=b;
        while(f[root])
            root=f[root];
        dfs(root);
        printf("%d\n",max(dp[root][0],dp[root][1]));
    }
    return 0;
}


posted @ 2016-03-14 13:21  martinue  阅读(111)  评论(0编辑  收藏  举报