单向TSP(Unidirectional TSP,UVa116) 【DP】

  这道题是刘紫书上的好题,这本书上的题真的应该好好练练。

先说一遍题意

  Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) — finding whether all the cities in a salesperson’s route can be visited exactly once with a specified limit on travel time — is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check. This problem deals with finding a minimal path through a grid of points while traveling only from left to right. Given an m×n matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i + 1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix “wraps” so that it represents a horizontal cylinder. Legal steps are illustrated on the right. The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited. For example, two slightly different 5×6 matrices are shown below (the only difference is the numbers in the bottom row). The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

 Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by m · n integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file. For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path’s weight will exceed integer values representable using 30 bits.

 Output

  Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

  Note: Lexicographically means the natural order on sequences induced by the order on their elements.         

Sample Input

5 6

3 4 1 2 8 6

6 1 8 2 7 4

5 9 3 9 9 5

8 4 1 3 2 6

3 7 2 8 6 4

5 6

3 4 1 2 8 6

6 1 8 2 7 4

5 9 3 9 9 5

8 4 1 3 2 6

3 7 2 1 2 3

2 2

9 10

9 10

Sample Output

1 2 3 4 4 5

16

 

1 2 1 5 4 5

11

 

1 1

19


意思就是
给一个n行m列的整数矩阵,从第一列任何一个位置出发每次往右或右下或右上走一格,最终到达最后一列。要求经过的整数之和最少。整个矩阵是环形的,即第一行的上一行是最后一行,最后一行的下一行是第一行。输出路径上每列的行号。多解时,输出字典序最小的。


 

分析

其实这道题和普通的dp差不了多少,只是要注意逆推,而且是环状的,不仅要ans还要输出字典序最小的,所以每次记一下行号就好了。

//by your panda
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<set>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxx 1e+7
using namespace std;

const int N=105;
const int M=15;
int n,m,ans;
int a[M][N],nextt[M][N];
int dp[M][N];

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        memset(nextt,0,sizeof(nextt));
        for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            scanf("%d",&a[i][j]);//存图 
        }
    }
    int ans=maxx,first=1;
    for(int j=m;j>0;j--)
    {
        for(int i=1;i<=n;i++)//逆推 
        {
            if(j==m)dp[i][j]=a[i][j];//边界 
            else
            {
                int road[3]={i-1,i,i+1};   //转移方法 
                if(i==1)road[0]=n;//环状 
                if(i==n)road[2]=1;//环状 
                sort(road,road+3);//字典序最小 
                dp[i][j]=maxx;
                for(int k=0;k<3;k++)
                {
                    
                    int v=dp[road[k]][j+1]+a[i][j];
                    if(v<dp[i][j])
                    {
                        dp[i][j]=v;
                        nextt[i][j]=road[k];
                    }
                }//状态转移 
            }
            if(j==1&&dp[i][j]<ans)
            {
                ans=dp[i][j];
                first=i;
            }    
        }
    }
    printf("%d",first);//输出第一行 
    for(int i=nextt[first][1],j=2;j<=m;i=nextt[i][j],j++)
    {
        printf(" %d",i);//其他行 
    }
    printf("\n%d\n",ans);//答案 
    }
    
    return 0;
}

 

posted @ 2018-06-11 10:56  那只憨态可掬的熊猫  阅读(141)  评论(0编辑  收藏  举报