POJ 1012 Joseph

Joseph
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 44650   Accepted: 16837

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30
题目大意:约瑟夫问题,总共有2 * k个人报数,前面k个是好人,后面k个是坏人,报道m的人要死去,问当m为何值时,坏人全部死去之前不会有好人死去。
解题方法:从1开始枚举m的值,遇到不满足的则将m加一再次枚举,知道满足为止。
复制代码
#include <stdio.h>

int main()
{
    int people[50] = {0}, k, Joseph[14] = {0};//Joseph用于打表,不然超时
    while(scanf("%d", &k) != EOF && k != 0)
    {
        if (Joseph[k] != 0)
        {
            printf("%d\n", Joseph[k]);
            continue;
        }
        int n = 2 * k;
        int m = 1;
        people[0] = 0;//people[0] = 0表示编号从0开始
        for (int i = 1; i <= k; i++)
        {
            //每次枚举完毕将剩下的人按从0到n - i编号,只要好人没有杀掉,则前面k - 1个编号是不变的
            people[i] = (people[i - 1] + m - 1) % (n - i + 1);
            if (people[i] < k)//第k个人的编号为k - 1,所以这里是<而不是<=
            {
                i = 0 ;
                m++;
            }
        }
        Joseph[k] = m;
        printf("%d\n", m);
    }
    return 0;
}
复制代码

 

posted on   lzm风雨无阻  阅读(3961)  评论(0编辑  收藏  举报

编辑推荐:
· AI与.NET技术实操系列:基于图像分类模型对图像进行分类
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
阅读排行:
· 分享一个免费、快速、无限量使用的满血 DeepSeek R1 模型,支持深度思考和联网搜索!
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 25岁的心里话
· ollama系列01:轻松3步本地部署deepseek,普通电脑可用
· 按钮权限的设计及实现
< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

导航

统计

点击右上角即可分享
微信分享提示