HDU OJ Common Subsequence

Common Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 7
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc abfcab
programming contest 
abcd mnp
Sample Output
4
2
0
分析:求两个字符串的最长公共子序列。
代码如下:

#include <iostream>
#include <cstring>
using namespace std;

char str1[1005];
char str2[1005];
int dp[1005][1005];

int main()
{
    int i,j;
    int Max;
    int len1,len2;
    while(cin>>str1>>str2)
    {
        len1=strlen(str1);
        len2=strlen(str2);
        for(i=0;i<len1;i++)
        {
            dp[i][0]=0;
        }
        for(i=0;i<len2;i++)
        {
            dp[0][i]=0;
        }
        for(i=1;i<=len1;i++)
        {
            for(j=1;j<=len2;j++)
            {
                if(str1[i-1]==str2[j-1])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else
                {
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        cout<<dp[len1][len2]<<endl;
    }
    return 0;
}

posted on 2012-02-17 16:15  lzm风雨无阻  阅读(1546)  评论(0编辑  收藏  举报

导航