流水依依

希望朋友们有个好的身体,开开心心工作与学习。

博客园 首页 新随笔 联系 订阅 管理

Caocao's Bridges

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
 

 

Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
 

 

Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.
 

 

Sample Input
3 3 1 2 7 2 3 4 3 1 4 3 2 1 2 7 2 3 4 0 0
 

 

Sample Output
-1 4
 

 

Source
 
#include <iostream>
#include <stdio.h>
#include <queue>
#include <stdio.h>
#include <string.h>
#include <vector>
#include <queue>
#include <set>
#include <algorithm>
#include <map>
#include <stack>
#include <math.h>
#define Max(a,b) ((a)>(b)?(a):(b))
#define Min(a,b) ((a)<(b)?(a):(b))
#pragma comment(linker, "/STACK:10240000000000,10240000000000")
using namespace std;
typedef long long LL ;
const int Max_N=1008 ;
struct Edge{
   int v ;
   int w ;
   int next ;
};
Edge edge[Max_N*Max_N] ;
int id  ,indx ;
int vec[Max_N] ,dfn[Max_N] ,low[Max_N] ;
bool visited[Max_N];
int grid[Max_N][Max_N] ;
vector<int>brige ;
void add_edge(int u ,int v ,int w){
     edge[id].v=v ;
     edge[id].w=w ;
     edge[id].next=vec[u]  ;
     vec[u]=id++ ;
}

void init(){
    id=0 ;
    indx=0 ;
    memset(vec,-1,sizeof(vec)) ;
    memset(visited,0,sizeof(visited)) ;
    memset(grid,0,sizeof(grid)) ;
    memset(dfn,0,sizeof(dfn)) ;
    brige.clear() ;
}

void dfs(int u ,int father){
    dfn[u]=low[u]=++indx ;
    for(int e=vec[u];e!=-1;e=edge[e].next){
        int v=edge[e].v ;
        int w=edge[e].w ;
        if(!dfn[v]){
            dfs(v,u) ;
            low[u]=Min(low[u],low[v]) ;
            if(low[v]>dfn[u]&&grid[u][v]==1)
                     brige.push_back(w) ;
        }
        else if(v!=father)
            low[u]=Min(low[u],dfn[v]) ;
    }
}

int Dot ;
void dfs(int u){
   visited[u]=1 ;
   Dot++ ;
   for(int e=vec[u];e!=-1;e=edge[e].next){
       int v=edge[e].v ;
       if(!visited[v])
            dfs(v) ;
   }
}

int main(){
    int N ,M ,u ,v ,w  ;
    while(scanf("%d%d",&N,&M)!=EOF){
        if(N==0&&M==0)
            break ;
        init() ;
        while(M--){
            scanf("%d%d%d",&u,&v,&w) ;
            add_edge(u,v,w) ;
            add_edge(v,u,w) ;
            grid[u][v]++ ;
            grid[v][u]++ ;
        }
        Dot=0 ;
        dfs(1) ;
        if(Dot!=N){
            puts("0") ;
            continue  ;
        }
        for(int i=1;i<=N ;i++){
              if(!dfn[i])
                   dfs(i,-1) ;
        }
        if(brige.size()==0){
             puts("-1") ;
             continue  ;
        }
        sort(brige.begin(),brige.end()) ;
        printf("%d\n",brige[0]==0?1:brige[0]) ;
    }
    return 0 ;
}

 

posted on 2013-10-30 18:40  流水依依  阅读(245)  评论(0编辑  收藏  举报