HDU 3172 并查集入门 Map容器

Virtual Friends

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9655    Accepted Submission(s): 2820


Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 

 

Input
Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 

 

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

 

Sample Input
1 3
Fred Barney
Barney Betty
Betty Wilma
 

 

Sample Output
2 3 4
 
 
题目大意:每次交朋友之后计算当前的朋友圈里有多少个朋友。
 
代码:

#include<bits/stdc++.h>
using namespace std;
int fa[100005];
int sum[100005];
int fi(int x)
{
if(fa[x]==x) return x;
return fa[x]=fi(fa[x]);
}
void unio(int x,int y)
{
x=fi(x);
y=fi(y);
if(x==y) return;
fa[x]=y;
sum[y]+=sum[x];
}
int main( )
{
int n,x1,x2,i,t1;
string name1,name2;
map<string,int>t;
while(~scanf("%d",&n))
{


while(n--)
{
scanf("%d",&t1);
for(i=0;i<=100005;i++)
{
fa[i]=i;
sum[i]=1;
}
t.clear( );
for(i=0;i<t1;i++)
{
cin>>name1>>name2;
if(!t.count(name1))
t.insert({name1,t.size()+1});
x1=t.at(name1);
if(!t.count(name2))
t.insert({name2,t.size()+1});
x2=t.at(name2);
//cout<<t.size();
//for(int j=1;j<=t.size();j++)
//cout<<t.at(name1)<<" "<<t.at(name2)<<endl;
unio(x1,x2);
printf("%d\n",sum[fi(x2)]);
}
}
}
return 0;
}

 

//因为名字的话相对数字来说不好储存对应的树关系 所以用了map容器 并查集思想是个模板水题 注意建立一个数组sum更新当前祖先下朋友圈的人数就行了

posted @ 2017-10-12 17:50  LiebeCelery  阅读(144)  评论(0编辑  收藏  举报