poj 1543 Perfect Cubes (暴搜)

Perfect Cubes
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15302   Accepted: 7936

Description

For hundreds of years Fermat's Last Theorem, which stated simply that for n > 2 there exist no integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusively unproven. (A recent proof is believed to be correct, though it is still undergoing scrutiny.) It is possible, however, to find integers greater than 1 that satisfy the "perfect cube" equation a^3 = b^3 + c^3 + d^3 (e.g. a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 is indeed true). This problem requires that you write a program to find all sets of numbers {a,b,c,d} which satisfy this equation for a <= N.

Input

One integer N (N <= 100).

Output

The output should be listed as shown below, one perfect cube per line, in non-decreasing order of a (i.e. the lines should be sorted by their a values). The values of b, c, and d should also be listed in non-decreasing order on the line itself. There do exist several values of a which can be produced from multiple distinct sets of b, c, and d triples. In these cases, the triples with the smaller b values should be listed first.

Sample Input

24

Sample Output

Cube = 6, Triple = (3,4,5)
Cube = 12, Triple = (6,8,10)
Cube = 18, Triple = (2,12,16)
Cube = 18, Triple = (9,12,15)
Cube = 19, Triple = (3,10,18)
Cube = 20, Triple = (7,14,17)
Cube = 24, Triple = (12,16,20)

 

Java AC 代码

import java.util.Scanner;

public class Main {
    
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        for(int i = 2; i <= n; i++)
            for(int a = 2; a < i; a++) 
                for(int b = a; b < i; b++) 
                    for(int c = b; c < i; c++) {
                        if(i*i*i == a*a*a + b*b*b + c*c*c) {
                            System.out.println("Cube = " + i +", Triple = (" + a + "," + b + "," + c +")");
                        }
                    }
    }
}

 

posted @ 2016-05-29 11:42  kk_kk  阅读(273)  评论(0编辑  收藏  举报