junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8166    Accepted Submission(s): 3354


Problem Description
Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
1 2 3 -4 1 1 1 1
 

Sample Output
39088 0
 

Author
LL
 

Source
题意:给定a,b,c,d,求在定义域内有多少种解。
# include <stdio.h>
# include <math.h>
# include <algorithm>
using namespace std;
int x[10001], y[10001];
int main()
{
    int a, b, c, d;
    while(~scanf("%d%d%d%d",&a,&b,&c,&d))
    {
        if(a>0&&b>0&&c>0&&d>0 || a<0&&b<0&&c<0&&d<0)//全为负数的剪枝快1s多。
        {
            puts("0");
            continue;
        }
        int k=0;
        long long ans = 0;
        for(int i=1; i<=100; ++i)
            for(int j=1; j<=100; ++j)
            {
                x[k] = a*i*i+b*j*j;
                y[k++] = c*i*i+d*j*j;
            }
        sort(x, x+k);
        sort(y, y+k);
        for(int i=0; i<k; ++i)
        {
            int l = 0, r = k-1, mid;
            long long tmp = 0;
            while(l<r)
            {
                mid = (l+r)>>1;
                if(x[i]+y[mid]<0)
                    l = mid+1;
                else
                    r = mid;
            }
            if(x[i]+y[r] == 0)
            {
                ++tmp;
                for(int t=r-1; t>=0&&x[i]+y[t]==0; ++tmp,--t);
                for(int t=r+1; t<k&&x[i]+y[t]==0; ++tmp,++t);
                ans += tmp;
                while(i+1 < k && x[i+1]==x[i])
                {
                    ++i;
                    ans += tmp;
                }
            }
        }
        printf("%lld\n",ans<<4);//因为是x^2,所以有2*2*2*2种情况。
    }
    return 0;
}



posted on 2017-02-19 11:43  junior19  阅读(126)  评论(0编辑  收藏  举报