HDU1250 Hat's Fibonacci (大数相加)(Java题解)

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14587    Accepted Submission(s): 4853

Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input

Each line will contain an integers. Process to end of file.

Output

For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 

代码如下:

import java.math.BigInteger;
import java.util.Scanner;
public class Main{
 static BigInteger f[]=new BigInteger[7045];
 public static void main(String[] args){
 dabiao();
 Scanner sc=new Scanner(System.in);
 while(sc.hasNext()){
 int n=sc.nextInt();
 System.out.println(f[n]);
   }
 }
 private static void dabiao(){
 f[1]=new BigInteger("1");
 f[2]=new BigInteger("1");
 f[3]=new BigInteger("1");
 f[4]=new BigInteger("1");
 for(int i=5;i<f.length;i++){
 f[i]=f[i-1].add(f[i-2]).add(f[i-3]).add(f[i-4]);
   }
 }
}
posted @ 2019-07-17 17:55  yyer  阅读(119)  评论(0编辑  收藏  举报