NYoj -Binary String Matching

Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
 
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
 
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 




使用find函数直接搜索。
int index = b.find(a, 0);
while(index != b.npos){
index = b.find(a, index + 1);
}


#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
int main(){
int t;
string a, b;
cin >> t;

while(t--){
cin >> a >> b;
int n = 0;
int index = b.find(a, 0);
while(index != b.npos){

n++;
index = b.find(a, index + 1);
}
cout << n << endl;
}
system("pause");
return 0;
}

 

posted @ 2018-04-02 19:19  那个人1  阅读(77)  评论(0编辑  收藏  举报