杭电 oj2602~(0-1背包问题)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 51417    Accepted Submission(s): 21634


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

 

Sample Output
14
 

 

Author
Teddy
 

 

Source
 
简单的0-1背包问题 ~
 
#include<iostream>
using namespace std;
int main()
{
    int t;
    int w[1050];
    int v[1050];
    int d[1050][1050];
    while(cin>>t)
    {
        while(t--)
        {
            int n,c;
            cin>>n>>c;

            for(int i=1;i<=n;i++)
                cin>>w[i];
            for(int i=1;i<=n;i++)
                cin>>v[i];
            for(int i=1;i<=n;i++)
                for(int j=0;j<=c;j++)
            {
                d[i][j]=(i==1?0:d[i-1][j]);
                if(j>=v[i]) d[i][j]=max(d[i][j],d[i-1][j-v[i]]+w[i]);
            }

            cout<<d[n][c]<<endl;

        }

    }
    return 0;
}

  

 
 
 
posted @ 2016-08-06 21:41  TomJarry  阅读(350)  评论(0编辑  收藏  举报