2013长沙赛区现场赛 J - Josephina and RPG

J - Josephina and RPG
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development. 
Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part. 
The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team gets victory only if they beat all the AI teams. 
Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her? 
 

Input

There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix T whose size is R × R. R equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains N integers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.
 

Output

For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable. 
 

Sample Input

4 0.50 0.50 0.20 0.30 0.50 0.50 0.90 0.40 0.80 0.10 0.50 0.60 0.70 0.60 0.40 0.50 3 0 1 2
 

Sample Output

0.378000
 
 
思路挺简单的dp,一开始读题有些错误,然后交G++被坑了。。。
dp[i][j]表示第i轮使用第j个队胜利的概率,然后dp[i][cp[i-1]]是由max(dp[i-1][j]*num[cp[i-1]][cp[i]])(i取所有队伍)来更新的。
 
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#define INF 0x3f3f3f3f
#define M(a,b) memset(a,b,sizeof(a))

using namespace std;

double num[125][125];
int cp[10050];
double dp[10050][125];

double max(double a,double b)
{
    if(a>b)  return a;
    else return b;
}

int main()
{
    int t;
    int r;
    while(scanf("%d",&t)==1)
    {
        int tp = 1;
        for(int i = t;i>t-3;i--) tp*=i;
        tp/=6;

        for(int i = 0;i<tp;i++)
            for(int j = 0;j<tp;j++)
        {
            scanf("%lf",&num[i][j]);
        }

        scanf("%d",&r);
        for(int i = 0;i<r;i++)
            scanf("%d",&cp[i]);

        for(int i = 0;i<tp;i++) dp[0][i] = num[i][cp[0]];

        for(int x = 1;x<r;x++)
        {
            dp[x][cp[x-1]] = 0;
            for(int i = 0;i<tp;i++)
            {
                dp[x][cp[x-1]] = max(dp[x][cp[x-1]],dp[x-1][i]*num[cp[x-1]][cp[x]]);
                if(i!=cp[x-1])
                dp[x][i] = dp[x-1][i]*num[i][cp[x]];
            }
        }

        double ans = 0;
        for(int i = 0;i<tp;i++)
           if(ans<dp[r-1][i]) ans = dp[r-1][i];
        printf("%.6f\n",ans);
    }
    return 0;
}

  

posted @ 2014-10-06 00:01  haohaooo  阅读(307)  评论(0编辑  收藏  举报