EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Exponentiation

Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 87049 Accepted: 20682

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and n is an integer 
C++

while(cin>>s>>n)
{
...
}
c
while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want
/*while(scanf(%s%d",s,&n)!=EOF) //this also work */
{
...
}

Source


高精度
import java.io.*;
import java.math.*;
import java.util.*;
import java.text.*;
 
public class Main {
    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        BigDecimal num;
        int ep, sta, end, i;
        String st;
        while(cin.hasNext()){                      //  相当于c++的!=EOF。
            num = cin.nextBigDecimal();
            ep = cin.nextInt();
            num = num.pow(ep);                     //  计算num^ep。
            st = new String(num.toPlainString());  //  toString()会有科学记数法。
            sta = 0;
            while(st.charAt(sta) == '0') sta ++;   //  去掉前缀的0。
            end = st.length() - 1;
            while(st.charAt(end) == '0') end --;   //  去掉后缀的0。
            if(st.charAt(end) == '.') end --;      //  若小数点后没0,去掉小数点。
            for(i = sta; i <= end; i ++)
                System.out.print(st.charAt(i));
            System.out.println();
        }
        System.exit(0);
    }
}
posted on 2011-06-09 15:28  Eric-Yang  阅读(216)  评论(0编辑  收藏  举报