EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Sequence Median

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11487 Accepted: 3273

Description

Given a sequence of N nonnegative integers. Let's define the median of such sequence. If N is odd the median is the element with stands in the middle of the sequence after it is sorted. One may notice that in this case the median has position (N+1)/2 in sorted sequence if sequence elements are numbered starting with 1. If N is even then the median is the semi-sum of the two "middle" elements of sorted sequence. I.e. semi-sum of the elements in positions N/2 and (N/2)+1 of sorted sequence. But original sequence might be unsorted. 

Your task is to write program to find the median of given sequence.

Input

The first line of input contains the only integer number N - the length of the sequence. Sequence itself follows in subsequent lines, one number in a line. The length of the sequence lies in the range from 1 to 250000. Each element of the sequence is a positive integer not greater than 2^32 - 1 inclusive.

Output

You should print the value of the median with exactly one digit after decimal point.

Sample Input

4
3
6
4
5

Sample Output

4.5

Hint

Huge input,scanf is recommended.

Source


 
float wa了
#include <cstdio>
#include <algorithm>

using namespace std;

int num[250001];
int n;
double median;

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&num[i]);
        sort(num+1,num+n+1);
        if(n%2==0)
        {
            median=((double)num[n/2]+(double)num[n/2+1])/2.0;
            printf("%.1f\n",median);
        }
        else
        {
            printf("%d.0\n",num[(n+1)/2]);
        }
    }
    return 0;
}
posted on 2011-06-08 18:08  Eric-Yang  阅读(305)  评论(0编辑  收藏  举报