HDU1159 Common Subsequence【最长公共子序列】

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
code:
View Code
#include<stdio.h>
#include<string.h>
int main()
{
char s1[1000],s2[1000]; //输入两个字符串序列
int r[1000],s[1000]; //DP记录状态转移结果,采用滚动数组节省空间
int l1,l2,i,j; //l1,l2记录两个字符串的长度
while(scanf("%s%s",s1,s2)!=EOF)
{
l1=strlen(s1);
l2=strlen(s2);
for(i=0;i<=l2;i++)
r[i]=0;
for(i=0;i<l1;i++)
{
for(j=0;j<l2;j++)
if(s1[i]==s2[j]) //如果序列对应字符相同
s[j+1]=r[j]+1;
else
s[j+1]=r[j+1]>s[j]?r[j+1]:s[j]; //如果序列对应字符不同,取大的一个
for(j=1;j<=l2;j++)
r[j]=s[j]; //数组往后滚动
}
printf("%d\n",r[l2]); //最大的字符串长度值是最后的元素值
}
return 0;
}

posted @ 2012-03-14 17:39  'wind  阅读(928)  评论(0编辑  收藏  举报