hdu Problem 2063 过山车

问题地址

过山车

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16720    Accepted Submission(s): 7304


Problem Description
RPG girls今天和大家一起去游乐场玩,终于可以坐上梦寐以求的过山车了。可是,过山车的每一排只有两个座位,而且还有条不成文的规矩,就是每个女生必须找个个男生做partner和她同坐。但是,每个女孩都有各自的想法,举个例子把,Rabbit只愿意和XHD或PQK做partner,Grass只愿意和linle或LL做partner,PrincessSnow愿意和水域浪子或伪酷儿做partner。考虑到经费问题,boss刘决定只让找到partner的人去坐过山车,其他的人,嘿嘿,就站在下面看着吧。聪明的Acmer,你可以帮忙算算最多有多少对组合可以坐上过山车吗?
 

Input
输入数据的第一行是三个整数K , M , N,分别表示可能的组合数目,女生的人数,男生的人数。0<K<=1000
1<=N 和M<=500.接下来的K行,每行有两个数,分别表示女生Ai愿意和男生Bj做partner。最后一个0结束输入。
 

Output
对于每组数据,输出一个整数,表示可以坐上过山车的最多组合数。
 

Sample Input
6 3 3 1 1 1 2 1 3 2 1 2 3 3 1 0
 

Sample Output
3
 

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define MAX_N 605
using namespace std;
int k, n, m;
bool map[MAX_N][MAX_N];
bool vis[MAX_N];
int match[MAX_N];
//利用DFS进行搜索
int findpath(int x) {
	//进行查找,寻找与x希望匹配的i。
	for(int i = 1;i <= n; i++) {
		//找到与x有意愿的匹配的i,标记i被访问。
		if(!vis[i] && map[x][i]) {
			vis[i] = true;
			//如果i未被匹配,或者DFS与i匹配的,如果可以交换,返回true。
			if(!match[i] || findpath(match[i])) {
				match[i] = x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int a, b;
	while (scanf("%d", &k) , k) {
		scanf("%d %d", &m, &n);
		int ans = 0;
		memset(match, false, sizeof(match));
		memset(map, false, sizeof(map));
		for (int i = 1; i <= k; i++) {
			scanf("%d %d", &a, &b);
			map[a][b] = true;
		}
		for(int j = 1; j <= m; j++) {
			memset(vis, false, sizeof(vis));
			if(findpath(j))  ans++;
		}
		printf("%d\n", ans);
	}
	return 0;
}


posted @ 2016-04-01 21:14  zprhhs  阅读(116)  评论(0编辑  收藏  举报
Power by awescnb