HDU 4442 Physical Examination (贪心+排序)

Physical Examination

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5985    Accepted Submission(s): 1682


Problem Description
WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er….. There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.
 

 

Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.
The input ends with n = 0.
For all test cases, 0<n≤100000, 0≤ai,bi<231.
 

 

Output
For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
 

 

Sample Input
5 1 2 2 3 3 4 4 5 5 6 0
 

 

Sample Output
1419
Hint
In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue, 169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his 120-core-parallel head, and decided that this is the optimal choice.
 

 

Source
 

 

Recommend
zhuyuanchen520

 

讨论2个的情况:

a1 b1

a2 b2

如果这是最优的顺序,则满足:

a1 + a1*b2 + a2 <= a2 + a2*b1 + a1

等价于

a1/b1 < a2/b2

a1*b2 < a2*b1

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int mod=365*24*60*60;
const int MAXN=100000+5;
struct node
{
    __int64 ai,bi;
    bool operator<(const node &B)const
    {
        return ai*B.bi<B.ai*bi;
    }
}a[MAXN];
int main()
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        __int64 ans=0;
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
            scanf("%I64d %I64d",&a[i].ai,&a[i].bi);
        sort(a,a+n);
        for(int i=0;i<n;i++)
        {
            if(i==0) ans+=a[i].ai;
            else ans+=(a[i].ai+ans*a[i].bi);
            ans=ans%mod;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
View Code
posted @ 2014-11-09 17:19  Cliff Chen  阅读(258)  评论(0编辑  收藏  举报