PAT(A) 1036. Boys vs Girls (25)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA
using namespace std;
#include <cstdio>

struct person
{
    char name[15];
    char id[15];
    char gender;
    int score;
}M, F, tmp;     //M为最低分男生的信息 F为最高分女生的信息 tmp暂存输入的个人信息

int main()
{
    //划重点(1):要求最小初始化为最大;求最大初始化为最小 (flag作用)
    M.score=101;    //待求男生的最低分
    F.score=-1;     //待求女生的最高分

    int n;
    scanf("%d", &n);
    for(int i=0; i<n; i++){
        //划重点(2):tmp暂存输入的个人信息,同时与flag(M.score & F.score)比较找出最小值最大值
        //划重点(3):%s能包括空格 %c只读取一个字母 故采用这种格式
        scanf("%s %c %s %d", &tmp.name, &tmp.gender, &tmp.id, &tmp.score);

        if(tmp.gender == 'M' && tmp.score<M.score)
            M=tmp;      //男生,且tmp的分数低于记录的M的分数,则更新M
        if(tmp.gender == 'F' && tmp.score>F.score)
            F=tmp;      //女生,且tmp的分数高于记录的F的分数,则更新F
    }
    //划重点(4):若初始化的分数(flag)未改变,则没有该种性别的学生
    if(F.score == -1) printf("Absent\n");    //没有女生
    else printf("%s %s\n", F.name, F.id);
    if(M.score == 101) printf("Absent\n");   //没有男生
    else printf("%s %s\n", M.name, M.id);
    if(F.score==-1 || M.score==101) printf("NA\n");
    else printf("%d", F.score-M.score);
    return 0;
}

 

posted @ 2017-03-14 13:59  claremz  阅读(193)  评论(0编辑  收藏  举报