cjweffort

博客园 首页 联系 订阅 管理

http://ac.jobdu.com/problem.php?cid=1040&pid=57

题目描述:

Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.

输入:

The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.

输出:

Output one line for each test case, that is, the K-th number module (%) 200907.

样例输入:
2
1 2 3 5
1 2 4 5
样例输出:
5
16
// 题目58:A sequence of numbers.cpp: 主项目文件。

#include "stdafx.h"
#include <cstdio>

long long ariSequence(long long first,long long base,long long k)
{
	return ((first%200907)+(((k-1)%200907)*(base%200907))%200907)%200907;
}

long long pow(long long base,long long power)
{
	if(power==0)
		return 1;
	if(power==1)
		return base%200907;
	long long res=1;
	if(power&0x01)
		res=base%200907;
	long long tmp=pow(base,power>>1)%200907;
	res=(res*((tmp*tmp)%200907))%200907;
	return res;
}

long long geoSequence(long long first,long long base,long long k)
{
	return ((first%200907)*(pow(base,k-1)%200907))%200907;
}

int main()
{
    int testCase;
	scanf("%d",&testCase);
	while(testCase--)
	{
		long long a1,a2,a3,k;
		scanf("%I64d%I64d%I64d%I64d",&a1,&a2,&a3,&k);
		long long res=0; 
		if(a2-a1==a3-a2)
			res=ariSequence(a1,a2-a1,k);
		else
			res=geoSequence(a1,(long long)(a2/a1)%200907,k);
		printf("%lld\n",res);
	}
    return 0;
}


posted on 2013-03-06 11:39  cjweffort  阅读(135)  评论(0编辑  收藏  举报