zoj1002

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

 

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4
直接上代码吧
#include <iostream>
#include <cstdlib>
#include <cmath>
#include <list>
#define OPEN 1
#define CASTLE 2
#define BLOCK 3
#define WALL 4
// summary: 用贪心原理找到一个影响地图最小的城堡的位置
// param in: map[] 输入的地图. n 地图大小.
// param out: min_x,min_y  得出的放置的城堡的x,y坐标
// return: true 找到了合适的位置. false 没有可以放置城堡的地方了
#define MAX_POINT 10000 // 哨兵数
bool FindMinInfluencePosition(int map[][4], int n, int &min_x, int &min_y)
{
    int min_point = MAX_POINT; // 赋哨兵值
    min_x = min_y = 0;

    for (int y = 0; y < n; y++)
    {
        for (int x = 0; x < n; x++)
        {
            if ( map[y][x] == OPEN)
            {
                int curr_point = 1;

                // 向上
                for (int j = y - 1; j >= 0 && map[j][x] != WALL; j--)
                {
                    if ( map[j][x] == OPEN)
                        curr_point++;
                }

                // 向下
                for (int j = y + 1; j < n && map[j][x] != WALL; j++)
                {
                    if ( map[j][x] == OPEN)
                        curr_point++;
                }

                // 向左
                for (int j = x - 1; j >= 0 && map[y][j] != WALL; j--)
                {
                    if ( map[y][j] == OPEN)
                        curr_point++;
                }

                // 向右
                for (int j = x + 1; j < n && map[y][j] != WALL; j++)
                {
                    if ( map[y][j] == OPEN)
                        curr_point++;
                }

                if (curr_point < min_point)
                {
                    min_point = curr_point;
                    min_x = x;
                    min_y = y;
                }
            }
        }
    }

    // 检测是否放置了城堡
    if (min_point != MAX_POINT)
        return true;
    else
        return false;

}

// summary: 根据位置放置城堡,在地图上标记出来
// param in: map[] 输入的地图. n 地图大小. x, y 放置的城堡的位置
void PlaceCastle(int map[][4], int n, int x, int y)
{
    map[y][x] = CASTLE;

    // 向上
    for (int j = y - 1; j >= 0 && map[j][x] != WALL; j--)
    {
        map[j][x] = BLOCK;
    }

    // 向下
    for (int j = y + 1; j < n && map[j][x] != WALL; j++)
    {
        map[j][x] = BLOCK;
    }

    // 向左
    for (int j = x - 1; j >= 0 && map[y][j] != WALL; j--)
    {
        map[y][j] = BLOCK;
    }

    // 向右
    for (int j = x + 1; j < n && map[y][j] != WALL; j++)
    {
        map[y][j] = BLOCK;
    }
}


int main ()
{
    int map[4][4];
    std::list<int> answer;//构造函数 
    int n;
    char c;

    // Read the data
    std::cin>>n;
    while (n != 0)
    {
        // Read map data
        for (int y = 0; y < n; y++)
        {
            for (int x = 0; x < n; x++)
            {
                std::cin>>c;
                if (c == '.')
                    map[y][x] = OPEN;
                else
                    map[y][x] = WALL;
            }
        }

        // Processing maps
        int castle_number = 0;
        int min_x, min_y;
        while (FindMinInfluencePosition(map, n, min_x, min_y) == true )
        {
            castle_number++;
            PlaceCastle(map, n, min_x, min_y);
        }

        // Record the data
        answer.push_back(castle_number);

        // Enter the next number
        std::cin>>n;
    }

    // The number of output
    for (std::list<int>::iterator it=answer.begin() ; it != answer.end(); ++it)
        std::cout <<*it<<"\n";

    return 0;
}

//菜鸟一枚,代码来自大神的博客,只是记录自己的学习,具体那一篇后来没找到,若有侵犯,楼主请留言



posted @ 2019-03-07 11:21  Maggieisxin  阅读(173)  评论(0编辑  收藏  举报