sdut 不敢死队问题

题目描述

说到“敢死队”,大家不要以为我来介绍电影了,因为数据结构里真有这么道程序设计题目,原题如下:

 

有M个敢死队员要炸掉敌人的一个碉堡,谁都不想去,排长决定用轮回数数的办法来决定哪个战士去执行任务。如果前一个战士没完成任务,则要再派一个战士上去。现给每个战士编一个号,大家围坐成一圈,随便从某一个战士开始计数,当数到5时,对应的战士就去执行任务,且此战士不再参加下一轮计数。如果此战士没完成任务,再从下一个战士开始数数,被数到第5时,此战士接着去执行任务。以此类推,直到任务完成为止。

 

这题本来就叫“敢死队”。“谁都不想去”,就这一句我觉得这个问题也只能叫“不敢死队问题”。今天大家就要完成这道不敢死队问题。我们假设排长是1号,按照上面介绍,从一号开始数,数到5的那名战士去执行任务,那么排长是第几个去执行任务的?

输入

输入包括多试数据,每行一个整数M(0<=M<=10000)(敢死队人数),若M==0,输入结束,不做处理。

 

输出

输出一个整数n,代表排长是第n个去执行任务。

示例输入

9
6
223
0

示例输出

2
6
132
#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat()
{
    struct node *head,*tail,*p;
    int i,n;
    p = (struct node *)malloc(sizeof(struct node));//��空�
    p->data = 1;//p������
    p->next = NULL;//�p��为�����个
    head = p;//�p�����头��
    tail = p;//�p�����尾��
    for(i = 2;i <= n;i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->data = i;
        tail->next = p;
        tail = p;
        p->next = NULL;
    }
    tail->next = head;//�尾��
    return head;
}//建��表�
int main ()
{
    int n,i,a[10010];
    struct node *head;
    while(scanf("%d",&n) != EOF)
    {
        if(n == 0) break;
        head = creat();
        int num = 1;//表示�����计����
        int count = 0;//表示�������计����
        struct node *p,*q;
        q = head;
        int m = 1;
        while(count <= n-1)
        {
            p = q->next;
            num++;
            if(num%5 == 0)
            {
                q->next = p->next;
                a[m] = p->data;
                m++;
                free(p);
                count++;
            }
            else q = p;
        }
        for(i = 1;i < m;i++)
            if(a[i] == 1)
                printf("%d\n",i);
    }
    return 0;
}

Runtime Error了。

 
 
稍微修改了一个地方就对了。
#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    struct node *head,*tail,*p;
    int i;
    p = (struct node *)malloc(sizeof(struct node));//��空�
    p->data = 1;//p������
    p->next = NULL;//�p��为�����个
    head = p;//�p�����头��
    tail = p;//�p�����尾��
    for(i = 2;i <= n;i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->data = i;
        tail->next = p;
        tail = p;
        p->next = NULL;
    }
    tail->next = head;//�尾��
    return head;
}//建��表�
int main ()
{
    int n,i,a[10010];
    struct node *head;
    while(scanf("%d",&n) != EOF)
    {
        if(n == 0) break;
        head = creat(n);
        int num = 1;//表示�����计����
        int count = 0;//表示�������计����
        struct node *p,*q;
        q = head;
        int m = 1;
        while(count <= n-1)
        {
            p = q->next;
            num++;
            if(num%5 == 0)
            {
                q->next = p->next;
                a[m] = p->data;
                m++;
                free(p);
                count++;
            }
            else q = p;
        }
        for(i = 1;i < m;i++)
            if(a[i] == 1)
                printf("%d\n",i);
    }
    return 0;
}

这个就对了。

posted @ 2013-05-02 14:40  幺小妖_  阅读(395)  评论(0编辑  收藏  举报