HDU-4864 Task

http://acm.hdu.edu.cn/showproblem.php?pid=4864

                                 Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2546    Accepted Submission(s): 657


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

 

Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

 

Sample Input
1 2
100 3
100 2
100 1
 

 

Sample Output
1 50004
 

 

Author
FZU
 

 

Source
 
 题意:有n个机器,m个任务。每个机器至多能完成一个任务。对于每个机器,有一个最大运行时间xi和等级yi,对于每个任务,也有一个运行时间xj和等级yj。只有当xi>=xj且yi>=yj的时候,机器i才能完成任务j,并获得500*xj+2*yj金钱。问最多能完成几个任务,当出现多种情况时,输出获得金钱最多的情况。
思路:贪心,先求出有多少机器满足任务数,然后用机器的最小等级数来匹配恰好满足的任务数。保证做的任务多,那么后面更加的大的水平数一定能够匹配后面的水平数,在时间满足条件的情况下。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int x,y;
}a[100005],b[100005];
bool cmp(node e,node f)
{
    if(e.x==f.x)
         return e.y>f.y;
    else
      return e.x>f.x;
}
int main()
{
    int n,m,i,j,c[100005],k,cnt;
             __int64 sum;
    while(~scanf("%d%d",&n,&m))
    {
        memset(c,0,sizeof(c));
        for(i=0;i<n;i++)
          scanf("%d%d",&a[i].x,&a[i].y);
        for(i=0;i<m;i++)
          scanf("%d%d",&b[i].x,&b[i].y);
               j=sum=cnt=0;
        sort(a,a+n,cmp);
        sort(b,b+m,cmp);
        for(i=0;i<m;i++)
        {
            while(j<n&&a[j].x>=b[i].x)
            {
                  c[a[j].y]++;//++不能使=1,为防止有相同的水平数y。
                   j++;
            }//找出所有大于任务的机器时间。
            for(k=b[i].y;k<=100;k++)//从该任务水平,一直到机器水平最小的那个数。保证做的任务多。
            //那么后面更加的大的水平数一定能够匹配后面的水平数,在时间满足条件的情况下。
            {

                if(c[k])
                 {
                    cnt++;
                    sum+=500*b[i].x+2*b[i].y;
                    c[k]--;
                    break;
                 }
            }
        }
        printf("%d %I64d\n",cnt,sum);
    }
    return 0;
}

 

posted @ 2014-07-25 10:33  疯狂的癫子  阅读(240)  评论(0编辑  收藏  举报