Codeforces Round #411 (Div. 2)D. Minimum number of steps(贪心)

传送门

Description

We have a string of letters 'a' and 'b'. We want to perform some operations on it. On each step we choose one of substrings "ab" in the string and replace it with the string "bba". If we have no "ab" as a substring, our job is done. Print the minimum number of steps we should perform to make our job done modulo 109 + 7.

The string "ab" appears as a substring if there is a letter 'b' right after the letter 'a' somewhere in the string.

Input

The first line contains the initial string consisting of letters 'a' and 'b' only with length from 1 to 106.

Output

Print the minimum number of steps modulo 109 + 7.

Sample Input

ab
aab

Sample Output

1

3

Note

The first example: "ab"  →  "bba".

The second example: "aab"  →  "abba"  →  "bbaba"  →  "bbbbaa".

思路

题解:要使最后的字符串不出现ab字样,贪心的从后面开始更换ab为bba,并且字符串以"abbbb..."形式出现的话,那么需要替换的次数就是b的个数,并且b的个数会翻倍,因此遍历查找存在"ab”子串的位置,然后开始替换,并记录下每个位置开始及其后面b的个数,然后更新答案即可。

 

#include<bits/stdc++.h>
using namespace std;
typedef __int64 LL;
const int mod = 1e9+7;
const int maxn = 1000005;
char str[maxn];
LL a[maxn];

int main()
{
	LL res = 0;
	scanf("%s",str);
	int len = strlen(str);
	if (str[len - 1] == 'b')	a[len-1] = 1; 
	for (int i = len - 2;i >= 0;i--)
	{
		if (str[i] == 'a' && str[i+1] == 'b')
		{
			res = (res%mod + a[i+1]%mod)%mod;
			a[i] = (2*a[i+1])%mod;
			str[i] = 'b';
		}
		else if ((str[i] == 'b' && str[i+1] == 'a') || (str[i] == 'b' && str[i+1] == 'b'))
		{
			a[i] = (a[i+1] +1)%mod;
		}
		else if (str[i] == 'a' && str[i+1] == 'a')
		{
			a[i] = a[i+1]; 
		}
	}
	printf("%I64d\n",res);
	return 0;
}

  

posted @ 2017-05-05 12:49  zxzhang  阅读(521)  评论(0编辑  收藏  举报