Codeforces Round #401 (Div. 2)B. Game of Credit Cards(贪心)

传送门

Description

After the fourth season Sherlock and Moriary have realized the whole foolishness of the battle between them and decided to continue their competitions in peaceful game of Credit Cards.

Rules of this game are simple: each player bring his favourite n-digit credit card. Then both players name the digits written on their cards one by one. If two digits are not equal, then the player, whose digit is smaller gets a flick (knock in the forehead usually made with a forefinger) from the other player. For example, if n = 3, Sherlock's card is 123 and Moriarty's card has number 321, first Sherlock names 1 and Moriarty names 3 so Sherlock gets a flick. Then they both digit 2 so no one gets a flick. Finally, Sherlock names 3, while Moriarty names 1 and gets a flick.

Of course, Sherlock will play honestly naming digits one by one in the order they are given, while Moriary, as a true villain, plans to cheat. He is going to name his digits in some other order (however, he is not going to change the overall number of occurences of each digit). For example, in case above Moriarty could name 1, 2, 3 and get no flicks at all, or he can name 2, 3 and 1 to give Sherlock two flicks.

Your goal is to find out the minimum possible number of flicks Moriarty will get (no one likes flicks) and the maximum possible number of flicks Sherlock can get from Moriarty. Note, that these two goals are different and the optimal result may be obtained by using different strategies.

Input

The first line of the input contains a single integer n (1 ≤ n ≤ 1000) — the number of digits in the cards Sherlock and Moriarty are going to use.

The second line contains n digits — Sherlock's credit card number.

The third line contains n digits — Moriarty's credit card number.

Output

First print the minimum possible number of flicks Moriarty will get. Then print the maximum possible number of flicks that Sherlock can get from Moriarty.

Sample Input

3
123
321

2
88
00

Sample Output

0
2

2
0

Note

First sample is elaborated in the problem statement. In the second sample, there is no way Moriarty can avoid getting two flicks.

思路

题意:A和B玩纸牌游戏,A按给定的顺序出牌,B可以按一定策略出牌,规定牌数大的人获胜,牌数相等平局。问B输的最少次数,以及A输的最大次数。

题解:要使B输的次数最少,则可以按照贪心策略,将两者的手牌从小到大排序,从后往前让B牌数大于等于A的牌数的两张牌配对,这样能尽可能大的保证B输的次数最少;类似的可求A输的最大次数。

 

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1005;

int main()
{
	//freopen("input.txt","r",stdin);
	int n,a[maxn],b[maxn];
	char astr[maxn],bstr[maxn];
	scanf("%d",&n);
	scanf("%s %s",astr,bstr);
	int len = strlen(astr);
	for (int i = 0;i < len;i++)
	{
		a[i] = astr[i] - '0';
		b[i] = bstr[i] - '0';
	}
	sort(a,a+len);sort(b,b+len);
	int minres = 0,p = len - 1;
	for (int i = len - 1;i >= 0;i--)
	{
		if (a[i] <= b[p])	p--,minres++;
	}
	int maxres = 0;
	p = len - 1;
	for (int i = len - 1;i >= 0;i--)
	{
		if (a[i] < b[p])
		{
			p--;
			maxres++;
		}
	}
	printf("%d\n%d\n",len - minres,maxres);
	return 0;
}

  

 

posted @ 2017-05-03 17:11  zxzhang  阅读(259)  评论(0编辑  收藏  举报