[kuangbin带你飞]专题五 并查集 A - Wireless Network

A - Wireless Network

题目链接:https://vjudge.net/contest/66964#problem/A

题目:

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
题意:说有n台电脑,给出n组电脑之间的关系,有关系则之间有一条线连接,后面若输入字符为O,则该台电脑与图中的电脑都建立一条线,若为S则判断后面输入的两台电脑是否有关系
思路:简单并查集题
//
// Created by hy on 2019/7/21.
//
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int maxn=2e4+10;
int father[maxn];
int p[maxn]={0};

struct Node{
    int x;
    int y;
}node[maxn];

int find(int x)
{
    if(x==father[x])
        return x;
    return father[x]=find(father[x]);
}

void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
        father[fx]=fy;
}

int main()
{
    int n,b;
    scanf("%d%d",&n,&b);
    for(int i=0;i<1005;i++)
        father[i]=i;
    for(int i=1;i<=n;i++)
        scanf("%d%d",&node[i].x,&node[i].y);
    char ch;
    int x,y;
    while(~scanf("%c",&ch))
    {
        if(ch=='O')
        {
            scanf("%d",&x);
            p[x]=1;
            for(int i=1;i<=n;i++)
            {
                if((node[i].x-node[x].x)*(node[i].x-node[x].x)+(node[i].y-node[x].y)*(node[i].y-node[x].y)<=b*b&&p[i]==1)
                    merge(i,x);
            }
        }
        if(ch=='S')
        {
            scanf("%d%d",&x,&y);
            int aa=find(x);
            int bb=find(y);
            if(aa==bb)
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }

    }
    return 0;
}

 


posted @ 2019-07-23 16:53  branna  阅读(192)  评论(0编辑  收藏  举报